
 

Sysgem Enterprise Manager 

User Guide 

 

 

 

 

 

 

 

 

By Sysgem AG 

 

 



 

 
Sysgem is a trademark of Sysgem AG. Other brands and products are registered trademarks of their respective 

holders. © 2000 Sysgem AG, Mühlebachstr. 84, CH-8008 Zürich, Switzerland, office@sysgem.com. All rights 

reserved. 

 

 



Sysgem Enterprise Manager User Guide Contents  ••••  i 

Contents 

Introduction 1 

What’s Inside .......................................................................................................................1 
Available Product Guides ....................................................................................................1 
Contacting Us ......................................................................................................................1 

Getting Started 2 

Starting the SEM Management Console (GUI) ...................................................................2 
Logging In ...........................................................................................................................2 
SEM Desktop.......................................................................................................................3 

Selection Window 5 

Selection Window Overview ...............................................................................................5 
Alarms .................................................................................................................................6 

Defining New Alarms............................................................................................6 
Setting Test Criteria in an Alarm...........................................................................7 
Defining Alarm Actions ......................................................................................10 
Applying Alarms .................................................................................................11 
Canceling Alarms ................................................................................................12 

Displays .............................................................................................................................12 
Standard SEM Displays.......................................................................................13 
Plug-in Application Module Displays .................................................................14 
Saved Displays ....................................................................................................14 

Filters .................................................................................................................................14 
Reports...............................................................................................................................15 

Customizing.........................................................................................................15 
Using ...................................................................................................................16 

Saved Sessions...................................................................................................................18 
Saving Sessions ...................................................................................................18 
Restoring Saved Sessions ....................................................................................19 

Tasks..................................................................................................................................19 
Defining a Task Script.........................................................................................20 
Using ...................................................................................................................20 

Virtual Desktop..................................................................................................................21 
Telnet...................................................................................................................21 
Virtual Network Computing (VNC)....................................................................23 
DOS Applications................................................................................................25 

Main Menu Options 27 

Main Menu Options Overview ..........................................................................................27 
File .....................................................................................................................................27 

Save Session ........................................................................................................27 
Print .....................................................................................................................27 
Print Preview .......................................................................................................27 
Print Setup ...........................................................................................................27 
Import and Export ...............................................................................................27 
Restart..................................................................................................................28 
Exit ......................................................................................................................28 



ii  ••••  Contents Sysgem Enterprise Manager User Guide 

View.................................................................................................................................. 28 
Toolbars.............................................................................................................. 28 
Alarm Bar ........................................................................................................... 28 
License Bar ......................................................................................................... 28 
Status Bar............................................................................................................ 28 
Select All ............................................................................................................ 28 
Deselect All ........................................................................................................ 29 
Full Screen.......................................................................................................... 29 

Display.............................................................................................................................. 29 
Save .................................................................................................................... 29 
Display as HTML ............................................................................................... 29 
Export List .......................................................................................................... 29 
Find..................................................................................................................... 30 
Start .................................................................................................................... 30 
Pause................................................................................................................... 30 
Stop..................................................................................................................... 30 
Column Widths................................................................................................... 30 
Row Headers ...................................................................................................... 30 
Zoom .................................................................................................................. 31 
Agents................................................................................................................. 31 
Connections ........................................................................................................ 31 
Column Layout ................................................................................................... 31 
Refresh Now....................................................................................................... 31 
Interval................................................................................................................ 31 
Security............................................................................................................... 31 
Alarm.................................................................................................................. 31 
Alarm off ............................................................................................................ 31 
Filter ................................................................................................................... 32 
Filter off.............................................................................................................. 32 
Chart ................................................................................................................... 32 

Chart ................................................................................................................................. 32 
Open ................................................................................................................... 32 
Save .................................................................................................................... 32 
Save Image ......................................................................................................... 33 
Print .................................................................................................................... 33 
Print Preview ...................................................................................................... 33 
Copy to Clipboard .............................................................................................. 33 
Data Averaging................................................................................................... 33 
Export ................................................................................................................. 33 
Fit Line to Data................................................................................................... 33 
Zoom .................................................................................................................. 33 
Info ..................................................................................................................... 33 
Erase ................................................................................................................... 34 
Auto-Archive ...................................................................................................... 34 
Properties............................................................................................................ 34 

Options.............................................................................................................................. 34 
Managers........................................................................................................................... 34 

Users ................................................................................................................... 34 
Agents................................................................................................................. 35 
Alarms ................................................................................................................ 35 
Displays .............................................................................................................. 36 
Filters.................................................................................................................. 36 
Reports................................................................................................................ 36 
Sessions .............................................................................................................. 36 
Tasks................................................................................................................... 36 
Virtual Desktop .................................................................................................. 36 
Explorer Menus .................................................................................................. 36 
Include Files ....................................................................................................... 37 
Integration Classes.............................................................................................. 37 
Templates ........................................................................................................... 37 



Sysgem Enterprise Manager User Guide Contents  ••••  iii 

Tools ..................................................................................................................................37 
Library Mappings ................................................................................................37 
Reload Mapped Definitions.................................................................................37 
Diagnostics ..........................................................................................................38 
ODBC..................................................................................................................38 
System .................................................................................................................39 
Web Publishing ...................................................................................................40 
Alarms Banner.....................................................................................................40 
Change Password ................................................................................................40 
License Manager .................................................................................................40 
Lock Program......................................................................................................40 
Security Key Manager .........................................................................................40 
Unattended Operation..........................................................................................40 
Add Desktop Icon................................................................................................43 
Settings ................................................................................................................43 

Favorites ............................................................................................................................47 
Manage Favorites ................................................................................................47 
Favorites Mode....................................................................................................47 

Window .............................................................................................................................47 
Cascade................................................................................................................47 
Tile ......................................................................................................................48 
Arrange Icons ......................................................................................................48 
Full Size...............................................................................................................48 
Optimize Layout..................................................................................................48 
Windows List ......................................................................................................48 
Alarms .................................................................................................................48 
Digital Clock .......................................................................................................48 
Display Cycler .....................................................................................................49 
Logfile .................................................................................................................49 

Toolbars 50 

Main Toolbar .....................................................................................................................50 
Main Toolbar Overview ......................................................................................50 
Toggle Selection Window ...................................................................................50 
Print .....................................................................................................................50 
Print Preview .......................................................................................................50 
Cascade Windows ...............................................................................................50 
Tile Windows ......................................................................................................51 
Full Size...............................................................................................................51 
Close All Windows..............................................................................................51 
Window List ........................................................................................................51 
Current Alarms ....................................................................................................51 
Logfile .................................................................................................................51 

Display Options Toolbar....................................................................................................52 
Display Options Toolbar .....................................................................................52 
Start .....................................................................................................................52 
Pause....................................................................................................................52 
Stop......................................................................................................................52 
Display as HTML................................................................................................52 
Export ..................................................................................................................52 
Find......................................................................................................................52 
Adjust Columns...................................................................................................53 
Autofit Column Widths .......................................................................................53 
Create Chart.........................................................................................................53 
Telnet...................................................................................................................53 

Chart Toolbar.....................................................................................................................54 

Favorites 55 

Accessing Favorites from the menu...................................................................................55 



iv  ••••  Contents Sysgem Enterprise Manager User Guide 

Accessing Favorites from the Selection Window ............................................................. 55 
Managing Favorites .......................................................................................................... 56 

Creating, Deleting or Renaming a Collection..................................................... 56 
Changing the Selection Window mode .............................................................. 56 
Importing a new Collection ................................................................................ 56 
Exporting an existing Collection ........................................................................ 57 
Selecting and Managing Items in a Collection ................................................... 57 

Caching Favorites ............................................................................................................. 59 
Caching or uncaching entire collections ............................................................. 59 
Caching individual items .................................................................................... 59 
Upgrading modules............................................................................................. 59 

Index 61 

 



Sysgem Enterprise Manager User Guide Introduction  ••••  1 

Introduction 

What’s Inside 
This is the guide to using the Sysgem Enterprise Manager (SEM) Base 

Framework on your systems.  

For further information see also the other available product guides (shipped with 

SEM and available from the Downloads section of the Sysgem web site). 

See also the SEM Release Notes for the latest features added to SEM. 

Available Product Guides 
1. SEM Installation Guide 

 The guide to installing and configuring the Sysgem Enterprise 

Manager (SEM) Base Framework on your systems. 

2. SEM User guide 

 The guide to using the Sysgem Enterprise Manager (SEM) Base 

Framework. 

3. SSyM User Guide 

 The guide to using the Sysgem System Manager (SSyM) Module. 

4. SAcM User Guide 

 The guide to using the Sysgem Account Manager (SAcM) Module. 

5. SSeM User Guide 

 The guide to using the Sysgem Security Manager (SSeM) Module. 

6. SDeM User Guide 

 The Guide to using the Sysgem Development Manager (SDeM) 

Module. 

Contacting Us 
Please contact your supplier or Sysgem AG at any time via Online Support on 

the Sysgem web page http://www.sysgem.com. 
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Getting Started 

Starting the SEM Management Console (GUI) 
From a Windows 2000/NT workstation run the program “SEM Client.exe”. The 

location of this program is dependent on your particular installation and may 

even be located on a central server to which you need a mapping to a network 

share. If SEM is installed on your local workstation, then start it with the 

Windows "Start" menu, by selecting the "Start" > "Programs" > "SYSGEM" > 

"SEM" menu option. 

For convenience, it may be desirable to have an icon on your NT desktop with a 

shortcut to “SEM Cient.exe”.  A menu option is available within SEM for 

creating a desktop icon (see Main Menu Options -> Tools -> Add Desktop Icon 

this user guide). 

Logging In 

 

To use Sysgem Enterprise Manager (SEM) you need to have access to an 

account on the SEM system. Enter your SEM username and password into the 

login fields: 

• Username 

• Password 

Your account has been defined on an NT Server machine running the Sysgem 

Authorization Server process. Your username and password will be validated on 

this machine. A pointer to this server is normally defined already under the 

“Authorization Server” – “Select” option on the logon window. You may have to 

define this the very first time you use it on your workstation. Select the option: 

• Authorization Server – Select… 

Enter the name (or IP address) of the machine running the SEM Authorization 

Server and enter the port number (which is normally 7250). 

If the Authorization Server is not available for any reason, then there may be an 

alternative server running on another machine. If so, select this alternative server 

until the main server is available again. SEM will always remember the “last” 

Authorization Server you accessed for validating your username and password. 
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SEM Desktop 
Having logged into SEM you will be presented with the SEM desktop: 

 

1. Title Bar 

The name of the SEM user account using the SEM Management Console is 

shown in the title bar across the top of the SEM desktop screen. 

2. Selection Window 

Use the “Selection Window” to set the context for activating and editing: 

• Alarms to trigger remedial procedures when an exception situation 

has occurred on a remote target system, 

• Display windows for monitoring and managing remote systems and 

applications, 

• Filters for modifying the displayed data in the SEM display 

windows, 

• Reports, 

• etc. 

The Selection Window can also show your favorite items if you have configured 

them; see the Favorites section of this user guide for more information. 

See the section Selection Window of this user guide for a full description of the 

SEM Selection Window. 

3. Main Menu Options 

All options in SEM are available from the main SEM menu bar. The options 

may change depending on whether any SEM display windows are active and 

selected. Some menu options may not be available if you do not have sufficient 

privileges set in your SEM user profile. 

See the section Main Menu Options of this user guide for a full description of the 

Main SEM pull down menu options. 
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4. Main Toolbar 

The main SEM toolbar provides shortcuts to the commonly used SEM menu 

options. The toolbar may be removed by de-selecting the main menu option 

“View” > “Toolbars” > “Main”. 

See the Main Toolbar section of this user guide for a full description of the Main 

SEM Toolbar. 

5. Display Options Toolbar 

The Display Options toolbar provides additional features that can be useful for 

working with the data displayed in a display window.  The toolbar may be 

removed by de-selecting the main menu option “View” > “Toolbars” > 

“Options”. 

See the Display Options Toolbar section of this user guide for a full description 

of the Options Toolbar. 

6. Chart Toolbar 

The Chart toolbar provides options with working with charts based on the data in 

a display window.  The toolbar may be removed by de-selecting the main menu 

option “View” > “Toolbars” > “Chart”. 

See the Chart Toolbar and Chart Menu sections of this user guide for a full 

description of the Chart Toolbar. 

7. Clock – see the section Main Menu Options -> Window -> Digital Clock of 

this user guide for a description of using and customizing the SEM Digital clock. 

8. Alarm and License Bars 

These are two scrolling text bars that appear at the bottom of the SEM desktop.  

The Alarm bar is displayed whenever an alarm is triggered, and gives a summary 

of the number of outstanding alarms in the scrolling text. Details of the 

outstanding alarms and the ability to cancel the alarms and the Alarm Bar are 

shown in the Alarm Status window, shown by double-clicking on the Alarm Bar. 

See also the section Selection Window  -> Alarms -> Defining Alarm Actions -> 

Canceling Alarms of this user guide. 

The License Bar gives a summary of the installed license and may be cancelled 

by de-selecting the “License Bar” option under the main pull-down menu 

“View”. See also the section Main Menu Options -> View -> License Bar of this 

user guide. 

9. Status Bar 

The status bar appears at the very bottom of the SEM desktop. Its main use is to 

show the progress of transactions with remote agents. On the right of the status 

bar are a number of icons that illuminate when there is communication activity 

with the remote SEM agents. 

Starting with the right-most icon, their purposes are to indicate that: 

• Information is being received from a remote agent. 

• Information is being transmitted to a remote agent. 

• Communication with remote agents is encrypted. 

• Information is being written to the SEM Archive database. 

• A message is being written to the logfile. 

• A script is running in the SEM GUI. 

It is also possible to get a description of each icon by displaying a tool-tip for 

each. To do this, move the mouse pointer over the icon and a tool-tip description 

will be displayed. 
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Selection Window 

Selection Window Overview 
 

  

Classic Mode Favorites Mode 

Navigating through the SEM menu options is made simple using the ‘sliding 

options’ in the SEM “Selection Window”. Examples of the Selection Window in 

both its modes are given above, but the number of options available to you will 

be dependent upon the type of license in use on your system, and the level of 

access granted to your SEM account.  
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In Classic mode, the Selection Window displays all items that are available to 

you based on your license, the level of access you have been granted to the 

system, and the libraries and users you currently have mapped.  In this mode, 

your available options are grouped by item type, and one sliding panel is present 

for each type. 

In Favorites mode, the Selection Window displays only those items you have 

included in your currently selected collection of favorites.  This mode can 

include any type of item the Selection Window can display, and so does not 

feature sliding panels grouping the items by type. 

You are likely to make most use of the “Displays” Selection pane, and so it is 

probably better to look at this section first. However the order described below is 

the order in which they appear in the Selection Window. 

The following will be described in this section of the User Guide: 

• Alarms 

• Displays 

• Filters 

• Reports 

• Sessions 

• Tasks 

• Virtual Desktop 

Alarms 
Alarms are used in conjunction with displays to detect potential errors and 

attempt to correct them and / or inform others of the error condition. 

Typical errors are:  

• Loss of network connection  

• Disk errors 

• Disk full 

• Printer off-line 

• Break-in attempts 

• Machines and processes not available 

Your alarm definition can interface to log files, SMS, pagers, help desk 

packages, etc. and/or run scripts to take corrective actions, as required. 

Use alarms to interface with products such as HP OpenView, Tivoli etc. by 

writing entries to the Windows NT event log, which is an easy way to pass 

information to these programs. 

A number of pre-packaged alarms are installed with the standard SEM Plug-in 

Application Modules. 

Defining New Alarms 

New alarms may be defined, or existing alarms modified using the “Edit” option 

in the Alarms selection pane. Alarms may be your own private alarms or copies 

of those distributed with the SEM Plug-in Application Modules. Make sure you 

select the appropriate “Edit” option for the required category of alarms. 
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Give an alarm a “Title” and define a text message that will be displayed, e.g. 

with any mail message generated when the alarm is triggered. 

  

The criteria used to determine that the alarm should be triggered are entered 

next, followed by the actions to be taken and the display types to which the 

alarms may be applied.  

Press the “Next” button to navigate through this form or directly jump to the 

appropriate page using the navigation “Wizard” bar on the left of the form.  

Setting Test Criteria in an Alarm 

   

   

Add new criteria by selecting the “+ New” button and selecting the appropriate 

display type, column title, match criteria, etc.  Edit an alarm distributed with one 

of the SEM Plug-in Application Modules to see an example. 
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The criteria is either a text value, for example the Disk Type contains a character 

string “DKA0”, or it is a numeric value, for example the percentage used for a 

disk > 80.  

Select the type of match to be made by clicking either Text or Number. 

If you clicked Text then you enter a value in the Value field, and select how the 

match is to be made: either Exact, Contains, or Does not contain. 

If you clicked Number then enter a numeric value in the Value field, and select 

how the match is to be made: either =, <, <=, >, >= or ! =. 

When you have finished entering values click OK to save the criterion. 

Multiple criteria may be defined for each test. You need to select whether all or 

any of the criteria are to be matched. Multiple tests can be defined per Alarm. 

Next you need to decide when the alarm should be applied. There are several 

options. See the Field “Raise the alarm:” as shown below: 

 

  

If, for instance, you wanted to set an alarm an the “NT Processes” display, and 

raise the alarm if any one of the processes you have defined is NOT present in 

the window, then do the following: 

• Define a criterion for each process name,  
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• Make the “Display Type” = “Custom” (for Custom Display), 

• Select the Column Title as “Image”, 

• Select the match type as “Text”, and type in the exact image name 

as it will appear in the NT Processes display under the Column 

entitled “Image”, 

• Place each criterion in its own “Test”, 

• Set each test as “Do Match All” Entries, 

• And finally, in the “Raise the alarm:” field select “Once per display 

– if ANY test conditions NOT matched”. 

When this alarm is applied to the NT Processes display window, it will raise an 

alarm if any of the defined processes are no longer shown in the image list. 

To prevent the alarm being used accidentally with the wrong display, you can 

select the correct display(s) that it should be applied to in the “Display” page of 

the Alarm definitions window. 
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Defining Alarm Actions 

   

   

Actions are invoked when an Alarm is triggered. You must select at least one 

action. 

Note: When the Actions are invoked, the Client Script and Server Script are 

invoked first, and can cancel the Alarm if so desired. 

The following options are available: 

• User Interface 

o Add entry to archive 

o Add entry to logfile 

o Play sound file 

o Restore user interface 

o Run script 

o Send mail 

• Server 

o Run script 

• Expiration 

• Repeats 

Add entry to archive 

This action adds an entry to the SEM Archive database in the ALARMDATA 

table. To see this entry select the ODBC Browser from the Tools menu. 

Add entry to event log 

This action adds an entry to the Windows 2000/NT Application Event Log. To 

view the event log select the NT Event Viewer from the Startup -> 

Administrative Tools menu. 
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Add entry to logfile 

This action adds an entry to the SEM logfile. To see this entry select the Alarms 

page of the logfile. 

Play sound file 

This action plays the sound file of your choice. You must select the sound file, 

e.g. from “\WINNT\Media\” . 

Restore user interface 

If the user interface is minimized then it is restored and brought to the top of the 

workstation above all other windows. 

Run script (User Interface) 

A PERL script runs on the workstation. This is the Client Script, described in the 

user guide for the optional Sysgem Development Manager (SDeM) Module. 

Send mail 

Send E-mail. You also specify the To:, Subject: and Text: fields. The description 

of the Alarm is added to the text, along with the Display entry, which triggered 

the alarm. 

Expiration 

This defines the number of minutes after which the alarm automatically expires. 

For example, if an alarm has been triggered because a printer is offline you set 

the alarm to expire after two hours as by that time a service engineer should have 

fixed the problem. 

Repeats 

The interval between repeats of the same alarm instance. For example, if you 

have designed an alarm to be triggered when a disk is more than 90% full, you 

do not want it sending E-mails every 5 minutes, so you may want to set the 

Repeats value to 120 (2 hours) or more. 

Run script (Server) 

A script that runs on the same server that returned the entry that triggered the 

alarm. 

For more details on writing a script to run either on the Client or the Server – see 

the user guide for the optional Sysgem Development Manager (SDeM) Module. 

Applying Alarms 

To apply alarms to a Display ensure the required display is the one currently 

selected and then just double-click on the alarm entry.  
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Canceling Alarms 

 

The alarm banner (blue scrolling bar at the bottom of the SEM desktop) is 

displayed as soon as an alarm is triggered. In the example above, a display 

window was monitoring a list of NT processes. An essential process (ftp.exe) 

had disappeared and caused the alarm to trigger. Instantly, the alarm banner was 

displayed. A summary of the number of outstanding alarms is shown in the 

banner text. Double clicking on the banner reveals the pop-up Alarm window 

giving the details of the alarm. Having identified the cause of the problem, the 

SEM user can now cancel the alarm and hide the banner using the icons at the 

top of the pop-up alarm window. 

Displays 
 “Displays” give the main interactive functionality of SEM.  

 

Depending on which SEM Plug-in Applications you have access to, there will be 

a number of library option trees that may be expanded and used. The above 
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example gives the standard SEM displays plus six optional SEM Plug-in 

Applications: 

• Sysgem Account Manager (SAcM) Module 

• Sysgem Account Manager (SAcM) Password Synchronizer 

• Sysgem Development Manager (SDeM) Module 

• Sysgem Security Manager (SSeM) Module 

• Sysgem System Manager (SSyM) SNMP Module 

• Sysgem System Manager (SSyM) Module 

Standard SEM Displays 

A set of standard displays ship with the SEM GUI framework: 

• Agent Connections 

• Events 

• File & Directory Explorer 

• Machines 

• Ping 

• Registry 

The File Security Explorer display is also present when you have a valid license 

for the SSeM Security Manager module. 

Invoke a display window by double-clicking on the icon in the selection tree. A 

prompt is made requesting the “SEM Agents” to be connected. The list of 

Agents last used will be displayed by default. 

Select the required set of Agents and press “OK”. 

Information from the selected Agents will then be presented in the display 

window. 

A summary of each of the standard SEM displays is shown below: 

Agent Connections  

Shows which SEM users are connected to the selected set of Agents, the time 

they established the connection, the SEM display windows being used, etc.  

Events 

Shows the content of the NT event logs from the multiply selected Agent 

machines. Details of each log entry can be viewed in a pop-up window. Entries 

can be saved in an ODBC database in a central repository. 

File & Directory Explorer 

A multi-platform file and directory explorer. Files can be individually selected, 

edited, deleted etc. Custom-built menu options can be added to take action on 

multiply selected files on remote systems using a script language appropriate to 

the target platform 

Machines 

Displays information from the Agent running on the multiply selected set of 

Agents. Shows operating system versions, system time, SEM Agent build 

number/date, etc. 
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Ping 

A TCP/IP ping showing availability and responsiveness of remote systems on 

the network. SEM Agents do not need to be installed on the target machines for 

this option. 

Registry 

Gives an explorer window of remote Windows 2000/NT systems and allows the 

registry on those remote systems to be browsed, modified, etc.  

Plug-in Application Module Displays 

Features provided by the optional SEM Plug-in Application Modules are 

described in detail in the Module Guides provided with each Plug-in Module. 

Saved Displays 

After a display window has been started, it can be “Saved” and restarted later. 

All characteristics that have been set on the display are also saved and restored 

when the “Saved Display” is restarted. This means, for example, that the list of 

Agents originally connected will be reconnected, any alarms or filters defined on 

the display are restored, any customizations re: color settings, column positions, 

size and shape of the window etc are all restored to the state they were in when 

the window was saved.  

To save a display select Save from the Display menu. The following is saved:  

• Alarm definition (if any)  

• Column width (in pixels)  

• Column order  

• Custom display definition (if you are saving a custom display)  

• Filter definition (if any)  

• Size and position of the window (geometry)  

• Refresh interval  

• Selected servers  

• Default sort column  

• Zoom factor  

Filters 
The contents of a display window may be filtered in one of 2 ways: 

• By use of the “Find” option.  

• By use of a permanent “Filter”. 

A dynamic way to filter information on display windows is to use the “Find” 

option. Select the “Find” option, pick a column from the window and define 

filter criteria on the content of that column. Up to 2 filter criteria may be chosen 

and used in combination to simply and quickly condense the amount of 

information displayed. 

The “Find” option is available on the main menu “Display” pull-down menu. 

The second method is to define a permanent “Filter” and apply that to the 

required display window. To apply a filter, first make sure the required display 
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has been selected. Then, move to the context of the “Filters” pane in the 

“Selection Window” and double click on the required filter. The filter will be 

automatically applied to the currently selected SEM display window, revealing 

just the required information and hiding the remainder. 

Any number of filters can be defined. 

Typical examples of filters are:  

• Disks with less than 30% free space 

• Accounts with logon errors 

• Printers that are off-line 

Check out the filters provided with the Sysgem System Manager (SSyM) 

Module. This gives a set of example system manager filters.  

Create your own set of filters and keep them permanently for subsequent use. 

Reports 
 

Reports are a fundamental part of any system management product.  

Typical examples are: 

 

• Accounts – Show new, modified and deleted accounts. 

• Security – show security breaches in the last 30 days. 

 

 

Customizing 

See the Guide to using the Sysgem Development Manager (SDeM) Module on 

your systems. 
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Using 

To start a report, just double-click on an entry in the “Reports” navigation pane 

in the SEM Selection Window. When you start a report the “Select” page is 

displayed. This shows a list of the data that has already been collected and stored 

in the Archive database.  

To create a report you must: 

• Collect data from an SEM server. 

• Analyze this data. 

Collecting Data 

From the Select page click the “Add Data” button. The “Add Data” page is 

displayed. 

 

 

Select the servers to be started then click Start. The data is collected from the 

selected servers and stored in the Archive database. 

When you have finished collecting data, click ”Prev” to return to the Select page. 

Analyzing Data 

To generate the report output: 

1. Select one or more database entries (for a comparison report you 

must select exactly two entries). 

2. Click “Next” to move to the “Create” page 
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3. Select the report type – analysis or comparison. 

4. Select the detail level – overview, brief or full. 

5. Select the Appearance: 

• Cover Page – gives company logo and address, 

• Table of Contents – check this box is a table of contents is 

required. 

• Use frames (only if Table of Contents is checked). If you 

check this then the contents are displayed in a separate frame 

to the left of the report.  

• Autostart HTML browser – if checked then the default HTML 

browser is started after the report has been created. 

6. Select a style sheet (css file) - or allow the default to be used.  

7. Click “Create” to create the report. 

If there are any input parameters defined then a pop-up window is displayed, 

where you select the report options. 
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The report is produced in HTML format. It can be viewed, mailed, saved, etc. 

 

  

Saved Sessions 
When you log out of SEM all display windows are closed and each one will need 

to be started again individually the next time you log into SEM. You may 

frequently open the same windows as used previously, and keep having to restart 

them all can be tedious. 

By using the “Saved Sessions” option it is possible to remember all windows 

that are currently open, and all characteristics about those windows such as 

which Agents they are connected to, which filters have been applied, and which 

Alarms are set, etc. 

When these windows are required again, the saved session can be selected and 

all the windows within it re-started in a single operation. Multiple saved sessions 

can be defined and saved with personalized names, giving a very powerful and 

convenient means of restarting monitoring and management activities. 

Saving Sessions 

To save the current displays select “Save Session” from the main “File” pull-

down menu. For each display window the following information is saved: 

• Column layout - titles and widths. 

• Display definition. 

• Filter (if any). 

• Alarm (if any). 

• Geometry - window position and size. 

• Refresh interval. 

• Servers. 

• Sort column. 

• Zoom factor. 
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When you save a session, you supply: 

• Title – a name to remember the purpose of the session. 

• Comment – a further description of the session (optional). 

• Folder – to categorize where to find this session in the selection 

tree (optional). 

Click “Save” to save the definition. 

Restoring Saved Sessions 

 

The saved sessions are displayed in the “Sessions” pane of the Selection 

Window. To restore a saved session double-click on one of these entries. All 

current display windows are closed and the display windows from the saved 

session are opened. 

If you do not want to close your existing windows, but want to add those from a 

saved session, then press the shift key at the same time as double clicking on the 

required saved session icon. 

Tasks 
Run personalized system manager scripts on remote target systems. 

SEM “Tasks” gives you, as a system manager, a powerful feature with the ability 

to run your own scripts on multiple, remote, target systems. You can see the 

results of running those scripts in a window in the SEM management console 

and there is no requirement for you to log into the remote systems. 

The scripts are written by you, in a language appropriate to the target systems, 

and are held in your own personal library.  You can if you wish share these 

libraries with other SEM users. 

Languages supported: 

• Windows 2000/NT: Perl 

• OpenVMS:  DCL 

• UNIX:  Korn Shell 
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Defining a Task Script 

Select the “Edit” option from within the “Tasks” pane of the Selection Window, 

give the task a name and then enter the required script into the appropriate page 

for the platform type needed. The task is available with its name as a selectable 

icon held in your own personal library. 

Using 

Double click on an appropriate task icon to display the task window: 

 

Select the appropriate set of Agent(s) and press “Start” to run the script on those 

remote system(s). The result of running the script is shown in the top portion of 

the tasks window.  

To modify the script and re-run it, simply press the “Next” button, make the 

necessary modification to the script before returning to the display (above) and 

re-running the modified script: 

Modify the script: 

 

Re-run the script by pressing “Prev” and then again press “Start”. 

In the above example, entering a single command line script showed all 

processes on a remote system. The script was then modified to stop one of those 
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processes identifying it by its process ID displayed on the first screen. Having 

stopped the process, the script then re-displays the list of processes again to 

verify that the process has indeed been stopped. 

Virtual Desktop 
The Virtual Desktop Environment of SEM provides the ability to: 

• Launch a Telnet client to automatically connect to remote systems 

and not only run an interactive terminal session but also 

(optionally) to run automated telnet scripts in those sessions, 

• Run the Virtual Network Computing (VNC) client and connect to 

remote systems with an interface (in a local window) to remote 

workstation sessions, 

• Launch other applications of the users own choice on the local 

workstation to run within an independent NT window, 

Telnet 

Defining 

From the “Virtual Desktop” pane in the “SEM Selection Window”, select the 

“Edit” option under “Telnet Clients”, and then opt to create a new Telnet Client. 

The following form is displayed: 

 

 

Enter a Title to identify this Telnet Client.  

Press “Next”: 

The Appearance window is displayed. 
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From this window you can set: 

• The color of normal text (usually black). 

• The color used to represent bold text (usually red). 

• The color of the background (usually white). 

• The font – you can only select a fixed width font. 

• Dimensions – the number of rows and columns displayed when the 

program next starts. 

Press “Next”  

Enter the connection details: 

 

  

Select the protocol as “telnet”. 

Select the Agent (or type the IP address). 

Press the “Dialogue Editor” button to enter login details: 
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Make sure any text input is terminated with carriage return, line field symbols. 

Any password information used in a telnet session is stored locally in an 

encrypted form. 

The other options available from the Setup menu are: 

• Exit on disconnect – the telnet client exits when the connection 

with the remote server is closed. 

• Hide startup screen – this is set in the configuration file – the 

startup displayed when the telnet client is started. 

• Send backspace as delete – a convenient key mapping. 

Using Telnet Sessions 

Just double-click on the icon for the appropriate telnet server. The system will 

launch a telnet window and automatically run the login sequence and optionally 

other scripts before giving an interactive session within that window. 

Trouble Shooting 

The diagnostics logfile contains information to help Sysgem AG resolve any 

unexpected problems you may have. 

Typical information you will find in this logfile is: 

• A list of all executable files and DLLs that have been loaded. 

• All status information written to the status bar at the bottom of the 

terminal window.  

• All diagnostic messages such as connection error, host not found. 

Virtual Network Computing (VNC) 

Defining Remote VNC Servers 

From the “Virtual Desktop” pane in the “SEM Selection Window”, select the 

“Edit” option under “Remote Desktops”, and then opt to create a new Remote 

Desktop. 

The following form is displayed: 
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Enter a Title to identify this VNC Server.  

Press “Next”. 

Enter the connection details for required remote desktop. 

 

 
 

Either select the SEM Agent by name or give its IP address. The password to be 

entered here is the VNC Server password as defined on the remote machine. This 

password is held in an encrypted form by the SEM Management Console, and 

needs to be changed on the Management Console whenever it changes on the 

remote system.  

If you wish the remote VNC Server to allow multiple clients to share your 

session check the “Request shared session” checkbox. Otherwise, if you want to 

ensure that you have an exclusive connection to that machine leave this box 

unchecked. 
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The default values for the other VNC client / server connection settings are 

normally sufficient.  

Press “OK” to complete the definition, and a new icon will appear under the 

Remote Desktop menu selection tree. 

Using VNC Remote Desktops 

Just double-click on the icon for the appropriate VNC server. The system will 

launch a VNC client window and automatically run the connection sequence to 

the remote server. The local window then operates as a virtual workstation 

display to that remote system.  

DOS Applications 

Defining a DOS Application in SEM 

From the “Virtual Desktop” pane in the “SEM Selection Window”, select the 

“Edit” option under “DOS Commands”, and then opt to create a new entry. The 

following form is displayed: 

 

 

Give the new entry a title describing the DOS command you are about to define. 

The example shown here is fore Windows 2000/NT Notepad. 

Press “Next”. 

Select the appropriate DOS application image to be invoked. In this example 

E:\WINNT|notepad.exe has been selected. 
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If you require the application to run independently of the SEM GUI, leave the 

checkbox “Wait for the command to complete (modal)” unchecked. However, if 

you think it more appropriate for the SEM user interface to wait for the 

application to complete before resuming, check this box. Normally it would be 

left unchecked as in the example and the notepad window generated will then be 

launched quite independent to the rest of the SEM user interface. 

Press “OK” to complete the definition. A new icon will appear under the “DOS 

Commands" menu selection tree. 

Using a DOS Application window from SEM 

Just double-click on the icon for the appropriate DOS command in the “Virtual 

Desktop” selection pane. The system will launch a new window and 

automatically run the DOS command within it. In the example shown above, a 

new Notepad text editor session is started on the local workstation.  
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Main Menu Options 

Main Menu Options Overview 
This section describes the pull-down menu options from the Main SEM 

Management Console user interface. It gives cross-references to other sections of 

this and other documents where the features are further described. 

File 

Save Session 

This option saves all SEM display windows that are currently invoked, together 

with all their characteristics such as which agents have been connected, which 

filters have been applied, and which alarms have been set.  

The option is described in more detail under the section Selection Window -> 

Saved Sessions of this user guide. 

Print 

This option prints the contents of the currently selected SEM display window to 

a printer. The printer and print characteristics can be selected in a standard print 

pop-up selection window. 

Print Preview 

This option displays a view of the printed output that will result if the above 

“Print” option is selected. 

Print Setup 

“Print Setup” allows the default printer to be changed, together with the printer 

settings. 

Import and Export 

Import and Export is further defined in the SEM Installation and Management 

Guide. This option has the following sub-menu options: 

• Export Module 

• Import License 

• Import Module 

• Installation Logfile 
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Restart 

This terminates the current SEM session and logs the user out of SEM. It 

automatically restarts a SEM session. If restarting as the same user, the login 

prompts are automatically answered and a new SEM session will be restarted. If 

you request to restart as a new user, then the login form will be displayed 

prompting for the username and password of the new user. 

There are two sub-menu options to “Restart”: 

• New User 

• Same User 

Exit 

This option terminates the current session of the SEM Management Console. 

 

View 

Toolbars 

This option displays (or hides) the various toolbars on the SEM Management 

Console user interface. Toolbars for selection are: 

• Main 

• Chart 

• Options 

• Selection 

Alarm Bar 

Any SEM alarms that have been triggered automatically display a scrolling 

alarm bar at the foot of the SEM desktop. This alarm bar can be removed from 

the display, or re-displayed using this menu option. 

License Bar 

The License Bar is normally hidden with a full permanent SEM license. It can be 

revealed or hidden again with this menu option. The license bar gives a summary 

of the active license, its termination date (if any), its registered owner, etc. Trial 

licenses that are about to expire cannot be hidden. 

Status Bar 

The Status bar is described further in the section Getting Started -> SEM 

Desktop of this user guide. It is positioned on the bottom edge of the SEM 

desktop and may be hidden or revealed with this menu option. 

Select All 

This option applies to the lines in the currently selected SEM display window. 

The content of all lines in the current window will be selected and highlighted 

with this option.  
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Deselect All 

This option de-selects all lines of data in the currently selected SEM display 

window. 

Full Screen 

This option maximizes the SEM desktop to the full extent on the workstation 

monitor. All menu bars, tool bars, status bars etc are hidden. A button allows the 

‘normal‘ display to be resumed. 

Display 

Save 

This option saves the current display as a SEM “Saved Display”. For a full 

description of this feature, see the section Selection Window -> Displays -> 

Saved Displays of this user guide. 

Display as HTML 

This option takes the content of the currently selected SEM display window and 

places it into an HTML report in a separate window. The window may be saved, 

printed, sent by e-mail, etc. 

Export List 

The format of the exported file may be selected as one of: 

• Single column, border  (padded out to include a frame) 

• Single column, no border (simple text) 

• Multi-column, tab spaced 

• Multi-column, tab spaced, extra formatting for spreadsheets 

If one or more lines from the display were selected, then you have the choice of 

exporting the selected lines only, or the entire display: 

• Select All or Selected (if enabled). 

You may then either send the exported list as an e-mail attachment, or save it in 

a file.  

To send it as e-mail, select the “E-Mail” button. 

To save it in a file select the “Display” button and from the displayed list select 

the type of file format you require, e.g.:  

• Excel spreadsheet 

• HTML document 

• Word document 

• Text file 

• Write document 

You may then save the document into an appropriate file. 



30  ••••  Main Menu Options Sysgem Enterprise Manager User Guide 

Find 

“Find” allows the currently selected SEM display window to be filtered so that 

only certain entries in the window are shown. See the section Selection Window -

> Filters  of this user guide for more information on “Find” and “Filters”.  

Start 

The refresh of information in the currently selected SEM display window can be 

paused or stopped with the menu options next described. It may be resumed with 

this option.  

Pause 

Refresh of data in the currently selected SEM display is temporarily paused with 

this menu option.  

Stop 

Refresh of data in the currently selected SEM display is stopped with this menu 

option. Restarting it with the “Start” option will start the refresh again from the 

beginning of its cycle. 

Column Widths 

Column widths in SEM display windows can be manually adjusted. All the 

columns in the currently selected SEM display window can be reset with the 

“Column Width” menu options. There are two sub-menu options: 

 

• Adjust Column Widths 

• Resize Column Widths 

“Adjust Column Widths” will adjust the width of each column so that the 

columns fit exactly into the displayed area. This means that if the display is 

using only part of the available space, then the columns are stretched to 

maximize the use of all the available space. If the columns already stretch 

beyond the visible area, and necessitate moving the scroll bar to see the entire 

display, then “Adjust Column Widths” will compress each column (hiding some 

data if necessary) to fit all columns into the visible area.  

“Resize Column Widths” is the default setting; it resizes columns to be as wide 

as the widest entry in each, and will scroll off the visible area if required.  

Row Headers 

There are two sub-menu options: 

• Reset Heights 

• Show Row Headers 

The height of each row in a SEM display window can be manually adjusted by 

selecting “Show Row Headers” (<Alt>R) and then manually stretching one row 

(and all rows will resize to the new height).  

“Reset Heights” will reset the row heights to the optimum for the currently 

selected SEM display window. 
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Zoom 

“Zoom” will increase or decrease the font size in the currently selected SEM 

display window. 

Agents 

“Agents” under the “Display” pull-down menu will display the start-up window 

to re-connect the agents in the currently selected SEM display window. 

Connections 

“Connections” displays a pop-up window giving the connection status for each 

agent in the currently selected SEM display window. 

Column Layout 

“Column layout” shows a list of all columns available for the SEM display 

window, and shows which columns are currently being displayed. Columns are 

set to be “hidden” or “in-view”, and the column order can be changed on this 

pop-up form. Check the box: “Save as default for this display” to save the 

settings for all new instances of this window. 

Refresh Now 

This option causes the information in the currently selected SEM display 

window to be regenerated on the target machine(s) and re-displayed in the 

display window. 

Interval 

The time interval for automatically refreshing information in a display window is 

modified with this option. 

Security 

This option shows a list of all SEM users who have access to the currently 

selected SEM display window, and which SEM “Profiles” and “Tokens” grant 

access to the window.   

Alarm 

This option allows an alarm to be selected and applied to the currently selected 

SEM display window. See the section Selection Window -> Alarms of this user 

guide for more information. 

Alarm off 

Choose this option to remove alarms set on the currently selected SEM display 

window. 
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Filter 

This option allows a filter to be selected and applied to the currently selected 

SEM display window. See the section Selection Window -> Filters of this user 

guide for more information. 

Filter off 

Choose this option to remove filters set on the currently selected SEM display 

window. 

Chart 

Display windows containing “Line Plotter” fields (green cells with a historical 

graph entry in each cell) may have the line plotter fields displayed as a chart in a 

separate window. See the section Main Menu Options -> Chart of this user 

guide for more details.  

Chart 
The SEM chart display below is monitoring the processor utilization of a remote 

NT Server, and is displaying the utilization accumulated by the top 5 processes. 

The display is being refreshed every 10 secs and the user has displayed the 

information pop-up window giving the details for the section of the chart 

immediately under the cursor pointer. 

 

Open 

This option opens an existing (saved or archived) image of a chart and re-

presents it in a normal chart display. 

Save 

The currently selected chart window is saved into a file and may subsequently be 

reviewed using the “Chart” > “Open” option. 
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Save Image 

This option saves the image of the chart for subsequent display in HTML format.  

The purpose is to allow the image of the chart to be mailed for viewing by 

someone who does not normally have access to SEM. Saving the chart as an 

image just captures the image of the display, and cannot be viewed as a normal 

SEM Chart and subsequently manipulated in a chart window as is possible after 

saving the data with the “Save” option. 

Print 

This option sends the image of the chart display to a printer. 

Print Preview 

Views the printed output as it would appear after printing the chart image on a 

printer. 

Copy to Clipboard 

Takes a snapshot of the chart image into the clipboard so that, for example, it 

may be included in a Word document. 

Data Averaging 

Often the detail of a chart hides the real underlying trends being shown. Using 

the “Data Averaging” option allows different length time slices to be chosen and 

the average value is calculated and displayed for each time slice and for each 

plot on the chart. This gives a better trending view of the situation being 

portrayed by the chart. 

Export 

Allows the chart data to be exported (either in its entirety or only selected lines) 

to a text file for use by other applications.   

Fit Line to Data 

Allows various statistical models to be used to fit a curve to the data points, and 

extrapolate future values for data. 

Zoom 

Select the Zoom option and the cursor changes to a vertical line covering the 

height of the chart. Sections of the chart may then be selected, and the selected 

area then becomes the only displayed are in the chart.  

Sections of the chart may be increasingly zoomed to give an ever more detailed 

view of that segment of the total display. Having zoomed-in by degrees, it is 

then also possible to zoom-out or simply revert back to the original. 

Info 

This option displays a pop-up window in the chart display immediately 

underneath the cursor position. It gives the details of the plotted items and the 

values assigned to each.  
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So for instance, if you were monitoring the processor utilization for the top 5 

CPU processes, then this option will display the names of the top 5 processes, 

plus their respective CPU utilization for the point on the graph indicated by the 

position of the cursor. Traverse the line with the cursor pointer, and each plot 

will reveal the different named entries and values in the pop-up window. 

Erase 

This option removes the entire set of graphical plots in the chart display window. 

Subsequent automatic refreshes of the window will then start to build up the 

chart data afresh. 

Auto-Archive 

Use the Auto-Archive option to periodically take a copy of the monitor data in a 

chart display and store it in compressed format in an archive file. The location 

and name of the archive file is selected, and a time period (e.g. every 12 hours) is 

defined. Also the type of data saved is selected from any combination of: 

• Chart Data 

• Image - JPG 

• Image - BMP 

• Image – PNG 

Subsequently this archive may be examined, and items returned into chart 

displays so that, for example, the same information from a previous period may 

be compared to the current figures.  

Properties 

The properties of the chart display is viewed and modified with this option. 

Options 
This list of menu options reflects the functionality of the currently selected SEM 

display window. As such, the detail of these menu options changes depending on 

which SEM display is currently selected. For a description of menu options 

available with SEM Plug-in Application Modules, see the appropriate SEM 

Plug-in Application Module user guide.  

Managers 

Users 

Before a user can invoke the SEM Management Console, the following actions 

must be taken for that user: 

• A SEM account must be created for the user 

• A SEM access control profile must be allocated to that account 

• The appropriate access control tokens for each SEM module 

needed must be assigned to the profile 

• Application Module libraries must be mapped to the account 
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All these actions are described in the SEM Installation Guide, and must be 

undertaken by the SEM “System” account or someone with SEM System 

privileges. 

The SEM Installation and Management Guide describes the following menu 

options under the Managers > Users main menu: 

• Accounts 

• Profiles 

• Tokens 

• Mappings 

• Agents 

• Settings 

• Become User 

Agents 

Defining a New Agent 

An Agent definition consists of:  

• Title - a name assigned to the agent entry.  

• Address - the IP address assigned to the server running the agent. 

This can be either a network address (a.b.c.d) or a host name from 

a host database.  

• Port - the port number assigned to the server, usually 7251.  

• Description - free text describing the server.  

• Enabled checkbox – Agents can be temporarily removed from 

displayed lists without loosing the definition. 

• Pingable checkbox – if the disabled flag is set, then check this box 

to make it available to the “Ping” display. 

Defining a New Agent Group 

A group definition consists of:  

• Title - a name assigned to the group entry.  

• Selected - one or more server definitions 

Search the Network for Machines 

To make it easy to define SEM Agents select “Search Network” from the “Agent 

Definitions” > “Tools” menu. 

You load definitions from either the primary domain name server (this uses the 

DOS utility nslookup) or from the local hosts file. 

Select the entries to be added, and then click “Add”. 

A confirmation window is displayed after the definitions have been added. 

Alarms 

This option invokes the Alarms Editor, first prompting for the library to edit. The 

libraries can be your own personal library, or those belonging to the SEM 
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modules. See the section Selection Window -> Alarms for further details on 

creating Alarms. 

Displays 

This option invokes the Custom Displays Editor, first prompting for the library 

to edit. The libraries can be your own personal library, or those belonging to the 

SEM modules. See the guide to using the Sysgem Development Manager 

(SDeM) Module on your systems for further details on editing Custom Displays. 

Filters 

This option invokes the Filters Editor, first prompting for the library to edit. The 

libraries can be your own personal library, or those belonging to the SEM 

modules. See the section Selection Window -> Filters of this user guide for 

further details on editing Filters. 

Reports 

This option invokes the Reports Editor, first prompting for the library to edit. 

The libraries can be your own personal library, or those belonging to the SEM 

modules. See the section Selection Window -> Reports  of this user guide for 

further details on using SEM Reports. 

Sessions 

This option invokes the Saved Sessions Editor, first prompting for the library to 

edit. The libraries can be your own personal library, or those belonging to the 

SEM modules. Normally, the mapped module libraries would not have any 

saved sessions associated with them, but there is nothing to stop these from 

being added per customer site. See the section Selection Window -> Saved 

Sessions of this user guide for further details on creating Saved Sessions. 

Tasks 

This option invokes the Tasks Editor, first prompting for the library to edit. The 

libraries can be your own personal library, or those belonging to the SEM 

modules.  See the section Selection Window -> Tasks of this user guide for 

further details on editing Task scripts. 

Virtual Desktop 

This option invokes the Virtual Desktop Editor, first prompting for the library to 

edit. The libraries can be your own personal library, or those belonging to the 

SEM modules. See the section Selection Window -> Virtual Desktop of this user 

guide for further details on creating new Virtual Desktops. 

Explorer Menus 

The SEM File and directory Explorer has the ability to add menus to take 

customer specific action on selected files and directories. See the section 

Selection Window -> Displays ->  Standard SEM Displays of this user guide for 

further details on the SEM Multi-Platform File and Directory Explorer. 
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Include Files 

Include files are used in developing SEM scripts to share common code (e.g. 

subroutines) between different script files. This menu option invokes the Include 

File Editor. See the guide to using the Sysgem Development Manager (SDeM) 

Module on your systems for further details on editing scripts and include files. 

Integration Classes 

Integration Classes are used in developing SEM scripts to invoke dynamic code. 

This menu option invokes the Integration Class Editor. See the SEM 

Development Manager Guide for further details on editing scripts and 

Integration Classes. 

Templates 

This option invokes the SEM Template Editor. Templates are used in filling in 

SEM forms during transaction processing with SEM Application Modules. For 

example during the creation of user accounts in the Sysgem Account Manager 

(SAcM) Module. 

Tools 

Library Mappings 

Sysgem’s optional application module policy allows standard and customized 

modules to be installed in any combination. However, all modules installed do 

not need to be available to all users of SEM. “Library Mappings” is the 

mechanism to control which SEM user has access to which application module. 

Select this option and see a list of all the application modules installed on this 

system. Check the boxes to give access to or remove access from any of the 

available modules. 

If you have the appropriate privileges, you can also map to the personal libraries 

of other SEM users. 

From a performance perspective, it is better to map to the minimum set of 

applications you need, since each mapped library has to be dynamically linked to 

your Management Console every time you log into SEM. Linking to 

unnecessary libraries not only takes time during the login process, but also 

increases the image size of your task unnecessarily. 

The SEM system manager should decide who should have access to which 

applications, and as a general rule remove the ability for non-privileged SEM 

users to have to change their mappings. 

Reload Mapped Definitions 

It is possible to have the latest library definitions re-mapped into your SEM 

Management Console without having to log out of SEM and back in again. Use 

the “Reload Mapped Definition” option if you think the system manager or 

someone else has updated the libraries. 

It is not necessary to manually “Reload Mapped Definitions” after you have 

updated or re-imported a module since this will happen automatically as part of 

that action. This option should normally only need to be run if someone else has 

updated a library. 
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Diagnostics 

This option invokes one of the following displays: 

• Add Test NT Event 

• Machines 

• Ping 

• Agent Connections 

• Stress Test Connections 

Add Test NT Event 

Add a test entry to a (remote) NT Event Log. Pick the NT Agent(s), set the text 

of the test message, and the type of log entry, and then press the “Apply” button 

on the “Create” page.  

Machines, Ping, Agent Connections 

“Machines”, “Ping”, and “Agent Connections” run the standard displays 

described under Selection Window -> Displays -> Standard SEM Displays of 

this user guide.  

Stress Test Connections 

“Stress Test Connections” adds an additional refresh interval to the currently 

selected SEM display.  

This option may be useful if you suspect the performance of a particular agent 

machine, or the communications links to that machine. For example start the 

“Machines” display and set an additional refresh interval to something very 

frequent with the “Stress Test Connections” option.  

To remove the additional refresh, simply restart the window to which it was 

applied. 

ODBC 

Sysgem Enterprise Manager uses ODBC-compliant databases to store 

information such as reports and to archive information such as script definitions. 

When you install Sysgem Enterprise Manager an empty Microsoft Access 

database file Access.mdb is created in the same directory as the User Interface 

executable. 

When you start Sysgem Enterprise Manager a check is made that the Data 

Source Names (DSN) required are defined. If not, a default is created. 

The tables are automatically created by Sysgem Enterprise Manager, and have 

been tested with Microsoft SQL Server, Microsoft Access and SYBASE.  

If you are using an ODBC-compliant product not listed here please contact 

Sysgem AG to arrange for the support (if necessary). 

ODBC Browser 

It is recommended that you use the ODBC Browser to view the contents of these 

databases. To start the browser select ODBC -> Browser from the Tools menu. 

Use the ODBC Browser to drill down to the area of interest. 

ODBC Browser Toolbar 

The options are, from left to right:  
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• Display the System and User DSNs.  

• Display the tables for the currently selected DSN.  

• Display the table privileges for the currently selected DSN.  

• Display the data types supported by the currently selected DSN.  

• Display the columns for the currently selected table.  

• Display the column privileges for the currently selected table.  

• Resize column widths to width of column contents.  

• Adjust column widths to use available space.  

• Sort alphabetically, ascending.  

• Sort alphabetically, descending.  

• Up a level (column -> table -> DSNs).  

• Export entries.  

Archive Database 

DSN = SSMArchive 

Access database = SSMArchive.mdb. 

The following tables are used by this database: 
 

Table Contents 

ALARMS A description of each alarm message. 

CUSDSPACTION The contents of each Custom Display 

menu action. 

REPORTDATA The data gathered for inclusion in reports. 

SCRIPTACTION The contents of each script. 

USERFILES When any definitions are saved to the 

Authorization Server a copy is also saved 

in this table. 

Security 

DSN = SSMSecurityLogs 

Access database = SSMSecurityLogs.mdb. 

The following tables are used by this database: 
 

Table  Contents 

NT_EVENTLOG Event log entries are archived here. 

System 

• Add Client Info to Logfile 

• Install ActiveX Controls 

• Internal Memory Buffers 

• Performance 

• Windows NT diagnostics… 
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Web Publishing 

A ‘placeholder’ of a feature for future release. 

Alarms Banner 

The Alarms Banner is identical to the Alarm Bar described in Getting Started -> 

SEM Desktop section of this user guide, but has the capability of much larger 

text, and in a window that can be positioned anywhere on the screen. 

Change Password 

Change your own SEM account password with this option. You are 

recommended to change the SEM password at frequent intervals. 

License Manager 

This option is used to configure the license installed on this system. Only the 

manager of SEM uses this option. Its use is described in detail in the “SEM 

Installation Guide”. 

Lock Program 

If you are leaving your desk for a period of time but want to leave SEM running 

then just select menu option (the shortcut key is ALT + L). 

SEM is locked, and a small login window is displayed. To continue using SEM 

you must enter your SEM password, then click “Continue”. 

Security Key Manager 

This option is used to configure the SEM Console Manager to be compatible 

with other SEM components. Only the manager of SEM uses this option. Its use 

is described in detail in the “SEM Installation Guide”. 

Unattended Operation 

Monitoring remote systems using an interactive SEM display with alarms set to 

detect exception conditions is very simple and convenient with SEM. However, 

it is often required to perform this monitoring job as an on-going activity 

whether or not someone is logged into SEM interactively. 

So, start the monitoring displays as an interactive session and save the active 

windows in a SEM Saved Session (see the section Selection Window -> Saved 

Sessions of this user guide) and then invoke the “Unattended Operation” option 

from the “Tools” pull-down menu giving it the “Saved Session”. 
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With the “Unattended Operation” mode of working, the SEM Management 

Console is run from within an NT Service, and as it starts it automatically 

invokes the set of displays given to it via the SEM Saved Session. In this way 

whether or not someone is logged into a SEM Management Console the 

background activity of running SEM monitor displays and raising alarms when 

exception conditions arise is always on going. 

If you then log into the NT account that is responsible for running this 

“Unattended Operation” you will see that the SEM Management Console is 

already running, and by typing in the SEM account password, you will be able to 

log in to SEM to see the interactive session already underway, and be able to see 

what the monitor displays are already doing. 

Disconnect Displays 

When selected, this option temporarily disconnects display windows from 

agents.  This is useful when creating or editing sessions for Unattended Mode, 

which may otherwise cause many agent connections to be made and so place 

undesired load upon target servers. 

To restore communications, select the option again to uncheck it. 

Service Displays 

In addition to the Unattended Operation mode, which uses saved (and therefore 

fixed) session definitions, SEM offers Service Displays to facilitate background 

processing. 

By selecting the “Service Displays” option from the “Tools” menu, the Service 

Displays Configuration dialog box is displayed. 

The “Service Displays” tab of this dialog box lists the available Service 

Displays.  Each of these represents a background task that can be configured for 

periodic operation, and selecting one will provide information on the 

functionality provided by each: 
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To enable a Service Display, click the “Add Configuration” button to create a 

new configuration; then use the “Schedule…” and “Parameters…” options to 

configure how and when the display should run.  Some displays allow multiple 

configurations to be created and enabled simultaneously. 

To disable a Service Display temporarily, select it and uncheck the “Enable this 

configuration” checkbox; if a display is to be permanently disabled, the 

configuration can also be deleted with the “Delete Configuration” button. 

Before Service Displays will run, the Service Display Host service must be 

installed using the “Service” tab of the dialog box.  This provides the same 

options as the “Unattended Operation” dialog, expect it does not allow a session 

to be selected.  Instead, the Service Display settings are inspected and the latest 

version of each selected display is started automatically. 

There is no need to restart the Service Display Host service when making 

changes to the Service Display configurations; any changes are applied 

automatically shortly after they are saved.  However, if a SEM Application 

Module is updated the service should be restarted to ensure the latest display 

definitions are available. 

The “Service” tab appears as follows: 
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Monitor Unattended Sessions 

The “Monitor Unattended Sessions” option on the “Tools” menu allows any 

running Unattended Operation or Service Display sessions to be monitored.  The 

displayed dialog shows a list of currently-running sessions, and allows more 

detailed information on display activity to be retrieved for each one. 

Add Desktop Icon 

Create an icon on your desktop that invokes the SEM Management Console. 

Settings 

Use this option to set your own preference settings. A multi-tab form is 

presented allowing the settings to be customized for the following: 

Alarms 

Use this option to select the display of any combination of the following when 

an alarm is triggered:  

• Alarm browser  

• Alarms dialog bar  

• Alarms status bar  
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Define the SMTP Mail information for outgoing messages resulting from an 

alarm being triggered: 

• SMTP Server Address 

• Senders Name  

 

Background 

Use this option to customize the background of Sysgem Enterprise Manager in 

much the same way that you define the wallpaper displayed on your Windows 

2000/NT desktop. 

Sysgem Enterprise Manager supports the windows bitmap (.bmp) format.  

• Search - select a new file.  

• Current - search for a new file in the current working directory.  

• Windows - search for a new file in the Winnt directory.  

You can also display all the files in the selected directory either sequentially or 

randomly. This removes the monotony of a single picture.  

• Cycle through directory - a new file is selected from the current 

directory after the specified interval has elapsed.  

• Randomize files - if selected the new file is selected at random 

from the current directory; otherwise the files are displayed in 

alphabetic order.  

• Superimpose filename - displays the filename at the bottom of the 

window.  

You also select how the file is displayed:  

• Tile - repeats the image until the whole window is covered.  

• Stretched - the image is stretched, maintaining the aspect ratio, 

covering the whole window.  

• Fit to window - the image is stretched / shrunk until the whole 

image can be displayed in the window without any clipping.  

• Center - centers the image in the window.  

Disabled - the image (if any) is not displayed, instead the default bitmap 

(product name / version / build) is displayed. 

Clock 

The position and the characteristics of the SEM Digital Clock are customized 

with this option. The clock may be: 

• Displayed on the SEM desktop background 

• Displayed in a pop-up window 

• Not displayed 

If the clock is displayed on the SEM desktop background, its position may be 

selected as a preference setting. 

Communications 

Add optional entries to the logfile. It is very unlikely that you will need to use 

these options - they are included to support development of Sysgem Enterprise 

Manager.  
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• Received messages - shows the contents of each incoming message 

structure from a Server.  

• Send messages - shows the contents of each outgoing message 

structure to a Server.  

• Summary of data loaded - as data is loaded (Alarms, Filters, 

Displays) a summary of the entries is displayed.  

• Status of save operations - as data is saved (Alarms, Filters, 

Displays) a summary of the entries is displayed.  

Encryption – select from:  

• None.  

• Fastest.  

• Most secure.  

List Displays 

Controls the appearance of the display windows.  

• Gridlines - displays dotted lines between each row and column.  

• Select whole row - when the user clicks on an entry the whole row 

is selected.  

• Default background - displays the default background color where 

there are insufficient rows or columns to completely fill the display 

window. When not checked the display's unused background color 

is the same as the used background color.  

• Scheme - select a predefined color / font scheme, or alternatively 

define your own by selecting Custom.  

• Geometry - optionally save / restore the position and size of each 

display window.  

Logfile 

Define the appearance of the logfile: 

• Prefix entries - add a timestamp (none, hh:mm, hh:mm:ss) to all 

entries.  

• Has buttons - displays plus (+) and minus (-) buttons next to parent 

items. The user clicks the buttons to expand or collapse a parent 

item's list of child items.  

• Has lines - uses lines to show the hierarchy of items.  

• Has lines at root - uses lines to link items at the root of the tree 

view control. This value is ignored if “Has lines” is not checked.  

Controls extra information that is written to the logfile. This is typically 

information required to debug custom scripts. 

Also, you can restrict the maximum number of entries for each tab in the logfile 

to avoid using too much memory. This is highly recommended. 

Marquee 

Control the speed and colors used by the Marquee - scrolling text window. 

ODBC 

Specify the connection strings for the Archive and Security databases. 
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Perl 

Add optional Perl flags, for example -w to aid debugging Perl scripts. 

When SEM starts it checks that you have a valid PERL configuration. 

Selection Window 

Select which of the sliding menu option panes are visible in the “Selection 

Window”. Choose any combination from the following (at least one must be 

selected): 

• Alarms 

• Displays 

• Filters 

• Reports 

• Sessions 

• Tasks 

• Virtual Desktop 

(See the section 
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Selection Window of this user guide for a description of the sliding menu option 

panes) 

Select which of the standard SEM Displays are visible in the “Displays” pane of 

the “Selection Window”: 

• Agent Connections 

• Events 

• Explorer 

• Machines 

• Ping 

• Registry 

(See the section Selection Window -> Displays -> Standard SEM Displays for a 

description of Standard SEM Displays). 

Socket 

The port used for incoming messages from servers. The default can be changed 

here. If the value selected is in use Sysgem Enterprise Manager automatically 

uses the next free port. 

Startup 

Optionally disable the screen saver. 

Select where your settings are stored:  

• Authorization server,  

• Local registry (quicker, less network traffic).  

Favorites 
This menu always shows your currently selected favorites, if any, and provides 

options for managing them.  For more information, please see the Favorites 

section of this user guide. 

Manage Favorites 

Use this option to select your currently selected favorites collection, or to modify 

the favorites contained in the collection. 

Favorites Mode 

This option switches the Selection Window between Classic mode and Favorites 

mode.  It is a shortcut for selecting the Manage Favorites option and changing 

the setting in that dialog. 

Window 

Cascade 

Use this option to cascade the SEM display windows on view. Any minimized 

display windows remain minimized. 
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Tile 

Use this option to tile the SEM display windows on view. Any minimized 

display windows remain minimized. 

Arrange Icons 

Icons for the active but “minimized” SEM displays are re-arranged as a dense set 

at the bottom of the SEM desktop. 

Full Size 

Use this option enlarge the currently selected window to take advantage of all 

available space in the SEM desktop. It only changes the one SEM display 

window currently selected. 

Optimize Layout 

This option is similar to “Tile”, but with “Optimize Layout” the size of the 

individual windows is not changed, whereas “Tile” will also make all the 

windows of a uniform size. 

Windows List 

This option gives a list of all active SEM displays and allows any to be selected, 

minimized, maximized, etc. 

Alarms 

This option displays the Alarms Status window, giving details of any 

outstanding alarms and giving the ability to cancel alarms. See also the section 

Selection Window -> Alarms -> Defining Alarm Actions -> Canceling Alarms of 

this user guide. 

Digital Clock 

The SEM Digital clock can be: 

• Displayed on the SEM desktop background 

• Displayed in a pop-up window 

• Not displayed 

The style of clock is set in the preferences settings (F8) window – see the 

preferences section under  Main Menu Options -> Tools -> Settings -> Clock of 

this user guide. 

To display the SEM Digital Clock: select “Digital Clock” from the Window 

menu (the shortcut key is F7). 

The current time is displayed, updated every second.  

If the clock is displayed as a pop-up window, the current day or date on the 

frame of the clock can be shown, just by clicking once anywhere on the clock 

face. 
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Display Cycler 

To display the Display Cycler Window select “Display Cycler” from the 

“Window” menu (the shortcut key is F9). 

This window is used to manually or automatically cycle through the display 

windows. Cycling through display windows means minimizing all windows 

except one. Often it is difficult to see all windows when many windows are 

being displayed. This option is designed to resolve that situation particularly 

when being used in a monitoring mode. Set the interval between cycles for the 

automatic cycling of SEM Display windows. To switch to a particular window 

double-click on an entry in the list. 

Select “Auto” to automatically cycle through the displays. 

Logfile 

Description 

The logfile window is a temporary repository for all messages originating within 

Sysgem Enterprise Manager. (Alarms also write information here). The content 

of this display window is periodically purged, and it is not retained between 

sessions. It is used purely for reference during the interactive session or for 

volatile diagnostic information if a problem has occurred. 

Logfile Options 

The options are, from left to right:  

• Expand whole tree.  

• Collapse whole tree.  

• Go to top of tree.  

• Go to bottom of tree.  

• Erase tree (requires confirmation).  

• Display all scripts sent to the servers.  

• Display all results returned from the servers.  

• Export the display.  

• Save output from current pane to a text file. All nodes are expanded 

before the entries are written. 

• Send via E-Mail - the output from the current pane is sent via E-

Mail. 
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Toolbars 

Main Toolbar 

Main Toolbar Overview 

The Main Toolbar has a number of icons, which relate one or all SEM display 

windows, or to generic features within the SEM Console Manager. The 

following is a list of icons available on the Main Toolbar: 

• Toggle Selection Window 

• Print 

• Print Preview 

• Cascade Windows 

• Tile Windows 

• Full Size 

• Close All Windows 

• Window List 

• Current Alarms 

• Logfile 

Toggle Selection Window 

The entire selection window can be removed (and replaced) by using this option. 

If an increased desktop size is required to temporarily view a large SEM display 

window, then use this option to hide (and later reveal) the Selection Window. 

Print  

Print the content of the currently selected SEM display window. 

Print Preview 

Give a view of the printed output of the currently selected SEM window before 

it is printed. 

Cascade Windows 

Use this option to cascade the SEM display windows on view. Any minimized 

display windows remain minimized. 
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Tile Windows 

Use this option to tile the SEM display windows on view. Any minimized 

display windows remain minimized. 

Full Size 

Use this option enlarge the currently selected window to take advantage of all 

available space in the SEM desktop. It only changes the one SEM display 

window currently selected. 

Close All Windows 

Use this option to stop all SEM displays and leave the SEM desktop empty. 

Window List 

This gives a list of all currently started SEM display windows and allows any to 

be (manually) selected and brought in view on top of the SEM desktop. 

Current Alarms 

Display the Alarm Status window giving the list and details of all outstanding 

alarms. Double clicking on the Alarm Bar has the same effect. 

Logfile 

This option displays the SEM Logfile window, which shows a set of events that 

have recently occurred during this login session. The information in this window 

is volatile; it is not preserved between SEM sessions.  

The purpose of the Logfile window is to be a temporary repository of activity 

logs that may, for example, give additional details of transactions, or may be of 

help for diagnostic purposes, should a problem be experienced. 

The content of the SEM Logfile may be exported, saved in a file, printed, or sent 

via e-mail. 

See also the section Main Menu Options -> Window -> Logfile of this user guide 

for further details on the content of the SEM Logfile. 
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Display Options Toolbar 

Display Options Toolbar 

The Display Options Toolbar has a number of icons, all of which relate to just 

one SEM display window - the currently selected SEM display window. The 

following is a list of icons available on the Display Options Toolbar: 

• Start 

• Pause 

• Stop 

• Display as HTML 

• Export 

• Find 

• Adjust Columns 

• Autofit Column Widths 

• Create Chart 

• Telnet 

Start 

Restarts the automatic refresh of the currently selected SEM display window. 

Pause 

Temporarily suspends the automatic refresh of the currently selected SEM 

display window. 

Stop 

Stops the automatic refresh of the currently selected SEM display window. On 

restarting, the refresh cycle will commence from the beginning of its cycle. 

Display as HTML 

Exports the content of the currently selected display in HTML format and 

displays it in an Internet explorer window. 

Export 

Exports the content of the currently selected display in a selectable format and 

allows it to be printed, filed, e-mailed, etc. See the section Main Menu Options   

-> Display -> Export List of this user guide for more details. 

Find 

Filters the content of the currently selected SEM display. See the section 

Selection Window -> Filters of this user guide for details. 
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Adjust Columns 

See the section Main Menu Options -> Display -> Column Widths of this user 

guide for a description of “Adjust Column Widths and Autofit Column Widths. 

Autofit Column Widths 

See the section Main Menu Options -> Display -> Column Widths of this user 

guide for a description of Adjust Column Widths and Autofit Column Widths. 

Create Chart 

Display windows with fields containing numerical values may have those fields 

displayed as a chart in a separate pane, and have the chart updated dynamically 

with the refresh of the display data. See the section Main Menu Options -> Chart 

of this user guide for more detail on this topic.  

Telnet 

Connects to the agent listed for the currently selected entry in the display. 
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Chart Toolbar 
The buttons on the chart toolbar reflects the options found on the Chart menu, 

and are (from top to bottom): 

• Open from Archive 

• Save to Archive 

• Save Image 

• Copy to Clipboard 

• Export Data 

• Data Averaging 

• Fit Line to Data 

• Analyze 

• Zoom 

• Information 

• Erase Data 

• Auto-Archive 

• Chart Properties 
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Favorites 

The Favorites feature of SEM allows you to create collections of displays, 

reports, tasks, alarms and filters that you use frequently, and provides easy 

access to these items through the Favorites menu or, optionally, the Selection 

Window. 

The Favorites feature also allows a favorite item to be made available even when 

you do not have the library or user providing the item mapped.  This can be used 

to speed up starting SEM in situations where not all features are required. 

Accessing Favorites from the menu 
The Favorites menu always displays the favorites in your currently-selected 

collection.  All items are displayed, although some may be unavailable and so 

shown as disabled.  This will be because the library or user containing the item is 

not mapped, or (in the case of filters and alarms) because the item is not relevant 

to the currently active display. 

 

 

Accessing Favorites from the Selection Window 
The Selection Window can be toggled between displaying all mapped libraries 

and users (Classic mode), or displaying your currently-selected Favorites 

collection (Favorites mode).  When in Favorites mode, only those items that are 

currently available are shown – items that would be greyed out on the Favorites 

menu are not displayed. 

Favorites mode can be toggled by selected the “Favorites mode” option on the 

Favorites menu, or by opening the “Manage Favorites” dialog box and changing 
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the “Selection Bar mode” option.  This dialog box can be opened either through 

the “Manage Favorites” option on the Favorites menu, or by clicking the  

button above the Selection Window. 

Managing Favorites 
Favorites are managed from within the Manage Favorites dialog box.  This can 

be opened either via the Manage Favorites option on the Favorites menu, or the 

 button above the Selection Window: 

 

Creating, Deleting or Renaming a Collection 

To create a new collection, click the Create button to the right of the collection 

list and enter a name for the new collection.  The Organize Favorites dialog will 

then be displayed for you to select favorites for the collection – see Selecting and 

Managing Items in a Collection. 

To rename or delete an existing collection, select it in the collection list and click 

the Rename or Delete button as appropriate. 

Changing the Selection Window mode 

The two radio buttons at the bottom of the dialog box allow you to change the 

mode of the Selection Window.  Changing the selected collection in the 

collections list will automatically set the Selection Window to Favorites mode. 

Importing a new Collection 

To import a collection, click the Import button and select the file containing the 

favorites.  The new collection will be displayed in the collections list; none of 

the items in the collection will be cached.  

Importing a collection only adds items to your Favorites list.  It does not import 

the items themselves – if you do not have the relevant libraries mapped or 

available the items will not be available. 
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Exporting an existing Collection 

To export a collection, select the collection in the collections list and click 

Export.  You will be prompted to save the exported collection; the resulting file 

can be used by other SEM users to add the collection to their own list of 

available collections. 

Exporting a collection does not export the actual items referred to by your 

favorites – the relevant libraries or users will have to be present on the SEM 

system you import the collection on before the favorites will be available. 

Selecting and Managing Items in a Collection 

The items within a collection can be modified by selecting the collection in the 

Manage Favorites dialog box and clicking the Modify button.  This displays the 

Organize Favorites dialog: 

 

Adding Items 

Click the Add button to display the Add Favorite dialog: 
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Select a user or library from the list at the top of the dialog, and the contents of 

that mapping will be shown in the tabs below.  Click OK to add the selected item 

to your favorites collection. 

To speed up adding multiple items to the collection, the most recently selected 

item will remain selected each time you click the Add button until you close the 

Organize Favorites dialog box. 

Renaming Items 

Select an item in the collection and change the name shown in the Name: text 

field below the collection.  You can also select the item and then click once on 

the name to edit it. 

Removing Items or Folders 

Select an item or folder in the collection and click Remove. 

Organizing Items into Folders 

Items may be organized into folders; to add a new folder, click the New Folder 

button and enter a name.  This will create a folder either inside the currently-

selected folder, or at the top level of the collection if the selected item was not a 

folder. 

Items and folders may also be rearranged within the tree by dragging and 

dropping them into new positions. 
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Caching Favorites 
Each item within a favorites collection can be made available even when you 

have not mapped the library containing the item.  This is known as ‘caching’ the 

favorite, and works by taking a copy of the entire definition of the item and 

storing it in your own personal favorites cache. 

By caching those items you use frequently, you can reduce SEM’s startup time 

by unmapping your libraries.  Since most libraries contain far more definitions 

than the average user ever accesses, this drastically cuts down on the amount of 

data that needs to be loaded by SEM.  You can also use this feature to create 

accounts that can only access a limited subset of SEM functionality, picking and 

choosing from multiple libraries and reorganizing the collection to suit 

individual workflow. 

SEM can only cache items for which a definition is currently loaded.  This 

means that it is recommended that you have all relevant libraries mapped before 

you start selecting many favorites to cache, since saving the favorites cache and 

changing your library mappings several times can take some time.  Once an item 

has been cached you can freely unmap the library without affecting access to the 

item.  

Caching or uncaching entire collections 

To cache an entire collection, open the Manage Favorites dialog, select the 

collection in the list and click the  button.  To uncache a collection, click 

the  button instead.  The Cached column for the collection will change to 

indicate the new status of the collection. 

Since SEM can only cache items for which a definition is currently mapped, you 

may find that this operation only caches some items in the collection.  In this 

case, the Cached column will display “Partially Cached”; check that you have all 

required libraries mapped, and try again. 

Caching individual items 

To cache or uncache an individual item, open the Organize Favorites dialog, 

select the item and tick or clear the “Make available even when library 

unmapped” checkbox. 

Since SEM can only cache items for which a definition is currently mapped, you 

may find that this checkbox is disabled if the source library or user is unavailable 

at the moment.  In this case, check that you have the library or user indicated 

above the checkbox mapped, and try again. 

If you uncache an item when the source library or user is unavailable, you will 

be prompted to confirm that you wish to uncache the item.  If you do so, the item 

will become unavailable until the relevant mapping is re-established. 

Upgrading modules 

When a new version of a module is imported using the Import Module option, 

the favorites cache of each user is scanned and checked for copies of items that 

have now been upgraded.  If any are found, the Import Module wizard will 

prompt to update these collections to ensure they remain up to date. 
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